udhcp: add PXELINUX config file option (code 209) definition
No binary (build failed)
—
(log yok)
| @@ -62,6 +62,7 @@ const struct dhcp_optflag dhcp_optflags[] = { | |
| { OPTION_U16 , 0x84 }, /* DHCP_VLAN_ID */ | |
| { OPTION_U8 , 0x85 }, /* DHCP_VLAN_PRIORITY */ | |
| #endif | |
| + | { OPTION_STRING , 0xd1 }, /* DHCP_PXE_CONF_FILE */ |
| { OPTION_6RD , 0xd4 }, /* DHCP_6RD */ | |
| { OPTION_STATIC_ROUTES | OPTION_LIST , 0xf9 }, /* DHCP_MS_STATIC_ROUTES */ | |
| { OPTION_STRING , 0xfc }, /* DHCP_WPAD */ | |
| @@ -128,6 +129,7 @@ const char dhcp_option_strings[] ALIGN1 = | |
| "vlanid" "\0" /* DHCP_VLAN_ID */ | |
| "vlanpriority" "\0"/* DHCP_VLAN_PRIORITY */ | |
| #endif | |
| + | "pxeconffile" "\0" /* DHCP_PXE_CONF_FILE */ |
| "ip6rd" "\0" /* DHCP_6RD */ | |
| "msstaticroutes""\0"/* DHCP_MS_STATIC_ROUTES */ | |
| "wpad" "\0" /* DHCP_WPAD */ | |
| @@ -149,8 +149,9 @@ enum { | |
| //#define DHCP_DOMAIN_SEARCH 0x77 /* RFC 3397. set of ASCIZ string, DNS-style compressed */ | |
| //#define DHCP_SIP_SERVERS 0x78 /* RFC 3361. flag byte, then: 0: domain names, 1: IP addrs */ | |
| //#define DHCP_STATIC_ROUTES 0x79 /* RFC 3442. (mask,ip,router) tuples */ | |
| - | #define DHCP_VLAN_ID 0x84 /* 802.1P VLAN ID */ |
| - | #define DHCP_VLAN_PRIORITY 0x85 /* 802.1Q VLAN priority */ |
| + | //#define DHCP_VLAN_ID 0x84 /* 802.1P VLAN ID */ |
| + | //#define DHCP_VLAN_PRIORITY 0x85 /* 802.1Q VLAN priority */ |
| + | //#define DHCP_PXE_CONF_FILE 0xd1 /* RFC 5071 Configuration File */ |
| //#define DHCP_MS_STATIC_ROUTES 0xf9 /* Microsoft's pre-RFC 3442 code for 0x79? */ | |
| //#define DHCP_WPAD 0xfc /* MSIE's Web Proxy Autodiscovery Protocol */ | |
| #define DHCP_END 0xff | |