Update examples/udhcp/udhcpd.conf
No binary (build failed)
—
(log yok)
| @@ -74,43 +74,49 @@ option staticroutes 10.0.0.0/8 10.127.0.1, 10.11.12.0/24 10.11.12.1 | |
| option 0x08 01020304 # option 8: "cookie server IP addr: 1.2.3.4" | |
| option 14 "dumpfile" | |
| - | # Currently supported options (for more info, see options.c): |
| - | #opt lease NUM |
| - | #opt subnet IP |
| - | #opt broadcast IP |
| - | #opt router IP_LIST |
| - | #opt ipttl NUM |
| - | #opt mtu NUM |
| - | #opt hostname STRING # client's hostname |
| - | #opt domain STRING # client's domain suffix |
| - | #opt search STRING_LIST # search domains |
| - | #opt nisdomain STRING |
| - | #opt timezone NUM # (localtime - UTC_time) in seconds. signed |
| - | #opt tftp STRING # tftp server name |
| - | #opt bootfile STRING # tftp file to download (e.g. kernel image) |
| - | #opt bootsize NUM # size of that file |
| - | #opt rootpath STRING # (NFS) path to mount as root fs |
| - | #opt wpad STRING |
| - | #opt serverid IP # default: server's IP |
| - | #opt message STRING # error message (udhcpd sends it on success too) |
| - | #opt vlanid NUM # 802.1P VLAN ID |
| - | #opt vlanpriority NUM # 802.1Q VLAN priority |
| + | # Currently supported options [hex option value] (for more info, see options.c): |
| + | #opt lease NUM # [0x33] |
| + | #opt subnet IP # [0x01] |
| + | #opt broadcast IP # [0x1c] |
| + | #opt router IP_LIST # [0x03] |
| + | #opt ipttl NUM # [0x17] |
| + | #opt mtu NUM # [0x1a] |
| + | #opt hostname STRING # [0x0c] client's hostname |
| + | #opt domain STRING # [0x0f] client's domain suffix |
| + | #opt search STRING_LIST # [0x77] search domains |
| + | #opt nisdomain STRING # [0x28] |
| + | #opt timezone NUM # [0x02] (localtime - UTC_time) in seconds. signed |
| + | #opt tftp STRING # [0x42] tftp server name |
| + | #opt bootfile STRING # [0x43] tftp file to download (e.g. kernel image) |
| + | #opt bootsize NUM # [0x0d] size of that file |
| + | #opt rootpath STRING # [0x11] (NFS) path to mount as root fs |
| + | #opt wpad STRING # [0xfc] Web Proxy Auto Discovery Protocol |
| + | #opt serverid IP # [0x36] default: server's IP |
| + | #opt message STRING # [0x38] error message (udhcpd sends it on success too) |
| + | #opt vlanid NUM # [0x84] 802.1P VLAN ID |
| + | #opt vlanpriority NUM # [0x85] 802.1Q VLAN priority |
| + | # RFC 5071: PXELINUX Options |
| + | #opt 0xd0 F100747E # [0xd0] magic |
| + | #opt pxeconffile STRING # [0xd1] |
| + | #opt pxepathprefix STRING # [0xd2] |
| + | #opt reboottime NUM # [0xd3] bootstrap timeout |
| # Options specifying server(s) | |
| - | #opt dns IP_LIST |
| - | #opt wins IP_LIST |
| - | #opt nissrv IP_LIST |
| - | #opt ntpsrv IP_LIST |
| - | #opt lprsrv IP_LIST |
| - | #opt swapsrv IP |
| + | #opt dns IP_LIST # [0x06] |
| + | #opt wins IP_LIST # [0x2c] |
| + | #opt nissrv IP_LIST # [0x29] |
| + | #opt ntpsrv IP_LIST # [0x2a] |
| + | #opt lprsrv IP_LIST # [0x09] |
| + | #opt swapsrv IP # [0x10] |
| # Options specifying routes | |
| - | #opt routes IP_PAIR_LIST |
| - | #opt staticroutes STATIC_ROUTES # RFC 3442 classless static route option |
| - | #opt msstaticroutes STATIC_ROUTES # same, using MS option number |
| + | #opt routes IP_PAIR_LIST # [0x21] |
| + | #opt staticroutes STATIC_ROUTES # [0x79] RFC 3442 classless static route option |
| + | #opt msstaticroutes STATIC_ROUTES # [0xf9] same, using MS option number |
| # Obsolete options, no longer supported | |
| - | #opt logsrv IP_LIST # 704/UDP log server (not syslog!) |
| - | #opt namesrv IP_LIST # IEN 116 name server, obsolete (August 1979!!!) |
| - | #opt cookiesrv IP_LIST # RFC 865 "quote of the day" server, rarely (never?) used |
| - | #opt timesrv IP_LIST # RFC 868 time server, rarely (never?) used |
| + | #opt logsrv IP_LIST # [0x07] 704/UDP log server (not syslog!) |
| + | #opt namesrv IP_LIST # [0x05] IEN 116 name server, obsolete (August 1979!!!) |
| + | #opt cookiesrv IP_LIST # [0x08] RFC 865 "quote of the day" server, rarely (never?) used |
| + | #opt timesrv IP_LIST # [0x04] RFC 868 time server, rarely (never?) used |
| # TODO: in development | |
| - | #opt userclass STRING # RFC 3004. set of LASCII strings. "I am a printer" etc |
| - | #opt sipserv STRING LIST # RFC 3361. flag byte, then: 0: domain names, 1: IP addrs |
| + | #opt userclass STRING # [0x4d] RFC 3004. set of LASCII strings. "I am a printer" etc |
| + | #opt sipsrv STRING LIST # [0x78] RFC 3361. flag byte, then: 0: domain names, 1: IP addrs |
| + | #opt ip6rd .... # [0xd4] IPv6 rapid deployment |
| @@ -154,8 +154,8 @@ enum { | |
| //#define DHCP_STATIC_ROUTES 0x79 /* 121: RFC 3442. (mask,ip,router) tuples */ | |
| //#define DHCP_VLAN_ID 0x84 /* 132: 802.1P VLAN ID */ | |
| //#define DHCP_VLAN_PRIORITY 0x85 /* 133: 802.1Q VLAN priority */ | |
| - | //#define DHCP_PXE_CONF_FILE 0xd1 /* 209: RFC 5071 Configuration File */ |
| - | //#define DHCP_PXE_PATH_PREFIX 0xd2 /* 210: RFC 5071 Configuration File */ |
| + | //#define DHCP_PXE_CONF_FILE 0xd1 /* 209: RFC 5071 Configuration file */ |
| + | //#define DHCP_PXE_PATH_PREFIX 0xd2 /* 210: RFC 5071 Path prefix */ |
| //#define DHCP_REBOOT_TIME 0xd3 /* 211: RFC 5071 Reboot time */ | |
| //#define DHCP_MS_STATIC_ROUTES 0xf9 /* 249: Microsoft's pre-RFC 3442 code for 0x79? */ | |
| //#define DHCP_WPAD 0xfc /* 252: MSIE's Web Proxy Autodiscovery Protocol */ | |