← Commit list

0567e72168

Daniel Stenberg
Daniel Stenberg
2026-04-14
SUCCESS Duration: 254s

Subject

tests: use %b64[] instead of "raw" base64

Binary

No binary (build failed)

Architecture & Compiler Flags

Architecture: x86_64-linux-gnu Compiler: gcc (Ubuntu 11.4.0-1ubuntu1~22.04.3) 11.4.0

—

Build Log

(log yok)

Commit Diff GitHub →

tests/data/test795+1 -1
@@ -64,7 +64,7 @@ User-Agent: curl/%VERSION
Accept: */*
B001 CAPABILITY
-B002 AUTHENTICATE PLAIN AHYA
+B002 AUTHENTICATE PLAIN %b64[%00v%00]b64%
B003 LIST "%TESTNUMBER0002" *
B004 LOGOUT
</protocol>
tests/data/test849+2 -2
@@ -14,7 +14,7 @@ RFC4616
<servercmd>
AUTH PLAIN
REPLY AUTHENTICATE +
-REPLY dXJzZWwAa3VydAB4aXBqM3BsbXE= A002 NO Not authorized
+REPLY %b64[ursel%00kurt%00xipj3plmq]b64% A002 NO Not authorized
</servercmd>
</reply>
@@ -42,7 +42,7 @@ IMAP plain auth with alt authorization identity (Not authorized)
<protocol crlf="yes">
A001 CAPABILITY
A002 AUTHENTICATE PLAIN
-dXJzZWwAa3VydAB4aXBqM3BsbXE=
+%b64[ursel%00kurt%00xipj3plmq]b64%
</protocol>
</verify>
</testcase>
tests/data/test893+2 -2
@@ -16,7 +16,7 @@ RFC5034
<servercmd>
AUTH PLAIN
REPLY AUTH +
-REPLY dXJzZWwAa3VydAB4aXBqM3BsbXE= -ERR Not authorized
+REPLY %b64[ursel%00kurt%00xipj3plmq]b64% -ERR Not authorized
</servercmd>
</reply>
@@ -44,7 +44,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u kurt:xipj3plmq --sasl-authzid ursel
<protocol crlf="yes">
CAPA
AUTH PLAIN
-dXJzZWwAa3VydAB4aXBqM3BsbXE=
+%b64[ursel%00kurt%00xipj3plmq]b64%
</protocol>
</verify>
</testcase>
tests/data/test953+2 -2
@@ -15,7 +15,7 @@ RFC4954
<servercmd>
AUTH PLAIN
REPLY AUTH 334 PLAIN supported
-REPLY dXJzZWwAa3VydAB4aXBqM3BsbXE= 235 Authenticated
+REPLY %b64[ursel%00kurt%00xipj3plmq]b64% 235 Authenticated
</servercmd>
</reply>
@@ -40,7 +40,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr
<protocol crlf="yes">
EHLO %TESTNUMBER
AUTH PLAIN
-dXJzZWwAa3VydAB4aXBqM3BsbXE=
+%b64[ursel%00kurt%00xipj3plmq]b64%
MAIL FROM:%[email protected]%GT
RCPT TO:%[email protected]%GT
DATA
tests/data/test954+2 -2
@@ -15,7 +15,7 @@ RFC4954
<servercmd>
AUTH PLAIN
REPLY AUTH 334 PLAIN supported
-REPLY dXJzZWwAa3VydAB4aXBqM3BsbXE= 501 Not authorized
+REPLY %b64[ursel%00kurt%00xipj3plmq]b64% 501 Not authorized
</servercmd>
</reply>
@@ -46,7 +46,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr
<protocol crlf="yes">
EHLO %TESTNUMBER
AUTH PLAIN
-dXJzZWwAa3VydAB4aXBqM3BsbXE=
+%b64[ursel%00kurt%00xipj3plmq]b64%
</protocol>
</verify>
</testcase>