tests: convert base64 data to %b64[]
No binary (build failed)
—
(log yok)
| @@ -105,7 +105,7 @@ http://test.remote.example.com.%TESTNUMBER:%HTTPPORT/path/%TESTNUMBER0002 --prox | |
| <protocol crlf="headers"> | |
| CONNECT test.remote.example.com.%TESTNUMBER:%HTTPPORT HTTP/1.1 | |
| Host: test.remote.example.com.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -115,7 +115,7 @@ Proxy-Connection: Keep-Alive | |
| CONNECT test.remote.example.com.%TESTNUMBER:%HTTPPORT HTTP/1.1 | |
| Host: test.remote.example.com.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -63,7 +63,7 @@ http://test.a.galaxy.far.far.away.%TESTNUMBER:%HTTPPORT/%TESTNUMBER --proxy http | |
| <protocol crlf="yes" nonewline="yes"> | |
| CONNECT test.a.galaxy.far.far.away.%TESTNUMBER:%HTTPPORT HTTP/1.1 | |
| Host: test.a.galaxy.far.far.away.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -84,7 +84,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm -L -d "stuff to | |
| <protocol crlf="yes"> | |
| POST /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Content-Length: 0 | |
| @@ -80,7 +80,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm --proxy http:// | |
| <protocol crlf="headers"> | |
| GET http://%HOSTIP:%HTTPPORT/%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -78,7 +78,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm --fail | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -110,7 +110,7 @@ line three | |
| four is the number of lines | |
| PUT /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Content-Length: 0 | |
| @@ -64,7 +64,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm -0 | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.0 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -48,7 +48,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER --proxy http://%HOSTIP:%HTTPPORT --proxy-us | |
| <protocol crlf="headers"> | |
| GET http://%HOSTIP:%HTTPPORT/%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -97,7 +97,7 @@ http://data.from.server.requiring.digest.hohoho.com/%TESTNUMBER --proxy http://% | |
| <protocol crlf="headers"> | |
| GET http://data.from.server.requiring.digest.hohoho.com/%TESTNUMBER HTTP/1.1 | |
| Host: data.from.server.requiring.digest.hohoho.com | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -38,7 +38,7 @@ http://a.galaxy.far.far.away/%TESTNUMBER --proxy http://%HOSTIP:%HTTPPORT --prox | |
| <protocol crlf="headers"> | |
| POST http://a.galaxy.far.far.away/%TESTNUMBER HTTP/1.1 | |
| Host: a.galaxy.far.far.away | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -68,7 +68,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u auser:apasswd --ntlm -d "junkelijunk" | |
| <protocol crlf="yes" nonewline="yes"> | |
| POST /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Content-Length: 0 | |
| @@ -225,7 +225,7 @@ Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| @@ -240,7 +240,7 @@ Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| @@ -250,7 +250,7 @@ Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| @@ -266,7 +266,7 @@ Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| @@ -285,7 +285,7 @@ Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| @@ -295,7 +295,7 @@ Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| @@ -193,7 +193,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER ntlm basic | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| @@ -208,7 +208,7 @@ Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| @@ -245,7 +245,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER ntlm digest | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| @@ -260,7 +260,7 @@ Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| @@ -259,7 +259,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER ntlm ntlm | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0100 HTTP/1.1 | |
| @@ -269,7 +269,7 @@ Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| @@ -279,7 +279,7 @@ Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0300 HTTP/1.1 | |
| @@ -289,7 +289,7 @@ Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0400 HTTP/1.1 | |
| @@ -299,7 +299,7 @@ Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0500 HTTP/1.1 | |
| @@ -102,7 +102,7 @@ Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /%TESTNUMBER0200 HTTP/1.1 | |
| @@ -96,7 +96,7 @@ http://test.remote.example.com.%TESTNUMBER:%HTTPPORT/path/%TESTNUMBER0002 --prox | |
| <protocol crlf="headers"> | |
| CONNECT test.remote.example.com.%TESTNUMBER:%HTTPPORT HTTP/1.1 | |
| Host: test.remote.example.com.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -96,7 +96,7 @@ http://test.remote.example.com.%TESTNUMBER:%HTTPPORT/path/%TESTNUMBER0002 --prox | |
| <protocol crlf="yes" nonewline="yes"> | |
| CONNECT test.remote.example.com.%TESTNUMBER:%HTTPPORT HTTP/1.0 | |
| Host: test.remote.example.com.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -71,7 +71,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER --proxy http://%HOSTIP:%HTTPPORT --proxy-us | |
| <protocol crlf="yes" nonewline="yes"> | |
| POST http://%HOSTIP:%HTTPPORT/%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -100,7 +100,7 @@ Content-Type: application/x-www-form-urlencoded | |
| postitPOST http://%HOSTIP:%HTTPPORT/%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -99,7 +99,7 @@ http://test.remote.example.com.%TESTNUMBER:%HTTPPORT/path/%TESTNUMBER0002 --prox | |
| <protocol crlf="yes" nonewline="yes"> | |
| CONNECT test.remote.example.com.%TESTNUMBER:%HTTPPORT HTTP/1.1 | |
| Host: test.remote.example.com.%TESTNUMBER:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Proxy-Connection: Keep-Alive | |
| @@ -77,7 +77,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm -d "data" -H "H | |
| <protocol crlf="yes" nonewline="yes"> | |
| POST /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Header1: yes | |
| @@ -103,7 +103,7 @@ Content-Type: application/x-www-form-urlencoded | |
| this is the blurb we want to upload | |
| POST http://test.remote.example.com/path/%TESTNUMBER HTTP/1.1 | |
| Host: test.remote.example.com | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| Content-Length: 0 | |
| @@ -103,7 +103,7 @@ Content-Type: application/x-www-form-urlencoded | |
| this is the blurb we want to upload | |
| POST http://test.remote.example.com/path/%TESTNUMBER HTTP/1.1 | |
| Host: test.remote.example.com | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| Content-Length: 0 | |
| @@ -108,7 +108,7 @@ Content-Type: application/x-www-form-urlencoded | |
| this is the blurb we want to upload | |
| POST http://test.remote.example.com/path/%TESTNUMBER HTTP/1.1 | |
| Host: test.remote.example.com | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| Content-Length: 0 | |
| @@ -99,7 +99,7 @@ Proxy-Connection: Keep-Alive | |
| GET http://test.remote.example.com/path/%TESTNUMBER HTTP/1.1 | |
| Host: test.remote.example.com | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -77,7 +77,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -76,7 +76,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -98,7 +98,7 @@ Accept: */* | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -111,7 +111,7 @@ Accept: */* | |
| GET /path/mine HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| Accept: */* | |
| GET /path/mine HTTP/1.1 | |
| @@ -94,7 +94,7 @@ Accept: */* | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -56,7 +56,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser%repeat[1100 x A]%:testpass --nt | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -41,7 +41,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u user:pass --ntlm | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -13,7 +13,7 @@ followlocation | |
| <servercmd> | |
| AUTH XOAUTH2 | |
| REPLY AUTHENTICATE + | |
| - | REPLY dXNlcj12AWF1dGg9QmVhcmVyIHMzY3IzdAEB B002 OK AUTHENTICATE completed |
| + | REPLY %b64[user=v%01auth=Bearer s3cr3t%01%01]b64% B002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data> | |
| HTTP/1.1 302 OK | |
| @@ -77,7 +77,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER --proxy-user testuser:testpass -x http://%H | |
| <protocol crlf="headers"> | |
| GET http://%HOSTIP:%HTTPPORT/%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Proxy-Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Proxy-Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| Proxy-Connection: Keep-Alive | |
| @@ -14,7 +14,7 @@ RFC4616 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTHENTICATE + | |
| - | REPLY AHVzZXIAc2VjcmV0 A002 OK AUTHENTICATE completed |
| + | REPLY %b64[%00user%00secret]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,7 +45,7 @@ IMAP plain authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -12,9 +12,9 @@ SASL AUTH LOGIN | |
| <reply> | |
| <servercmd> | |
| AUTH LOGIN | |
| - | REPLY AUTHENTICATE + VXNlcm5hbWU6 |
| - | REPLY dXNlcg== + UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 A002 OK AUTHENTICATE completed |
| + | REPLY AUTHENTICATE + %b64[Username:]b64% |
| + | REPLY %b64[user]b64% + %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,8 +45,8 @@ IMAP login authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE LOGIN | |
| - | dXNlcg== |
| - | c2VjcmV0 |
| + | %b64[user]b64% |
| + | %b64[secret]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -13,8 +13,8 @@ RFC2195 | |
| <reply> | |
| <servercmd> | |
| AUTH CRAM-MD5 | |
| - | REPLY AUTHENTICATE + PDE5NzIuOTg3NjU0MzIxQGN1cmw+ |
| - | REPLY dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== A002 OK AUTHENTICATE completed |
| + | REPLY AUTHENTICATE + %b64[%3c1972.987654321@curl%3e]b64% |
| + | REPLY %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -49,7 +49,7 @@ IMAP CRAM-MD5 authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE CRAM-MD5 | |
| - | dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== |
| + | %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -14,7 +14,7 @@ NTLM | |
| <servercmd> | |
| AUTH NTLM | |
| REPLY AUTHENTICATE + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| REPLY TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= A002 OK AUTHENTICATE completed | |
| </servercmd> | |
| <data crlf="yes"> | |
| @@ -51,7 +51,7 @@ IMAP NTLM authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| @@ -13,8 +13,8 @@ RFC2831 | |
| <reply> | |
| <servercmd> | |
| AUTH DIGEST-MD5 | |
| - | REPLY AUTHENTICATE + cmVhbG09ImN1cmwiLG5vbmNlPSI1MzAwZDE3YTFkNjk1YmQ0MTFlNGNkZjk2Zjk1NDhjMjNjZWQ2MTc1IixhbGdvcml0aG09bWQ1LXNlc3MscW9wPSJhdXRoIg== |
| - | REPLY dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJpbWFwLzEyNy4wLjAuMSIscmVzcG9uc2U9YmU2MzgyNDkzNjJkN2FhMGUzNTM4NTA3Njc1MWFiNDgscW9wPWF1dGg= + cnNwYXV0aD04MWY5MDNlYjQ4MjNhZTkyMmRiNWYwNGNiNThjY2RlYg== |
| + | REPLY AUTHENTICATE + %b64[realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",algorithm=md5-sess,qop="auth"]b64% |
| + | REPLY %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="imap/127.0.0.1",response=be638249362d7aa0e35385076751ab48,qop=auth]b64% + %b64[rspauth=81f903eb4823ae922db5f04cb58ccdeb]b64% |
| REPLY A002 OK AUTHENTICATE completed | |
| </servercmd> | |
| <data crlf="yes"> | |
| @@ -55,7 +55,7 @@ IMAP DIGEST-MD5 authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE DIGEST-MD5 | |
| - | dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJpbWFwLzEyNy4wLjAuMSIscmVzcG9uc2U9YmU2MzgyNDkzNjJkN2FhMGUzNTM4NTA3Njc1MWFiNDgscW9wPWF1dGg= |
| + | %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="imap/127.0.0.1",response=be638249362d7aa0e35385076751ab48,qop=auth]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| @@ -14,7 +14,7 @@ RFC6749 | |
| <servercmd> | |
| AUTH XOAUTH2 | |
| REPLY AUTHENTICATE + | |
| - | REPLY dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB A002 OK AUTHENTICATE completed |
| + | REPLY %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,7 +45,7 @@ IMAP OAuth 2.0 (XOAUTH2) authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE XOAUTH2 | |
| - | dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -45,7 +45,7 @@ IMAP plain authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| - | A002 AUTHENTICATE PLAIN AHVzZXIAc2VjcmV0 |
| + | A002 AUTHENTICATE PLAIN %b64[%00user%00secret]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -14,8 +14,8 @@ SASL-IR | |
| <servercmd> | |
| AUTH LOGIN | |
| CAPA SASL-IR | |
| - | REPLY AUTHENTICATE + UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 A002 OK AUTHENTICATE completed |
| + | REPLY AUTHENTICATE + %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,8 +45,8 @@ IMAP login authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| - | A002 AUTHENTICATE LOGIN dXNlcg== |
| - | c2VjcmV0 |
| + | A002 AUTHENTICATE LOGIN %b64[user]b64% |
| + | %b64[secret]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -51,7 +51,7 @@ IMAP NTLM authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| - | A002 AUTHENTICATE NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | A002 AUTHENTICATE NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| @@ -45,7 +45,7 @@ IMAP OAuth 2.0 (XOAUTH2) authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| - | A002 AUTHENTICATE XOAUTH2 dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | A002 AUTHENTICATE XOAUTH2 %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -15,7 +15,7 @@ SASL CANCELLATION | |
| AUTH NTLM | |
| CAPA LOGINDISABLED | |
| REPLY AUTHENTICATE + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + Rubbish |
| REPLY * A002 NO AUTH exchange cancelled by client | |
| </servercmd> | |
| </reply> | |
| @@ -49,7 +49,7 @@ IMAP NTLM graceful cancellation | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| </protocol> | |
| </verify> | |
| @@ -18,7 +18,7 @@ AUTH CRAM-MD5 PLAIN | |
| REPLY "AUTHENTICATE CRAM-MD5" + Rubbish | |
| REPLY * A002 NO AUTH exchange cancelled by client | |
| REPLY "AUTHENTICATE PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 A003 OK AUTHENTICATE completed |
| + | REPLY %b64[%00user%00secret]b64% A003 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -55,7 +55,7 @@ A001 CAPABILITY | |
| A002 AUTHENTICATE CRAM-MD5 | |
| * | |
| A003 AUTHENTICATE PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| A004 SELECT %TESTNUMBER | |
| A005 FETCH 1 BODY[] | |
| A006 LOGOUT | |
| @@ -15,10 +15,10 @@ SASL DOWNGRADE | |
| <servercmd> | |
| AUTH NTLM PLAIN | |
| REPLY "AUTHENTICATE NTLM" + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + Rubbish |
| REPLY * A002 NO AUTH exchange cancelled by client | |
| REPLY "AUTHENTICATE PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 A003 OK AUTHENTICATE completed |
| + | REPLY %b64[%00user%00secret]b64% A003 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -54,10 +54,10 @@ IMAP NTLM authentication with SASL downgrade | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| A003 AUTHENTICATE PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| A004 SELECT %TESTNUMBER | |
| A005 FETCH 1 BODY[] | |
| A006 LOGOUT | |
| @@ -18,7 +18,7 @@ AUTH DIGEST-MD5 PLAIN | |
| REPLY "AUTHENTICATE DIGEST-MD5" + Rubbish | |
| REPLY * A002 NO AUTH exchange cancelled by client | |
| REPLY "AUTHENTICATE PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 A003 OK AUTHENTICATE completed |
| + | REPLY %b64[%00user%00secret]b64% A003 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -57,7 +57,7 @@ A001 CAPABILITY | |
| A002 AUTHENTICATE DIGEST-MD5 | |
| * | |
| A003 AUTHENTICATE PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| A004 SELECT %TESTNUMBER | |
| A005 FETCH 1 BODY[] | |
| A006 LOGOUT | |
| @@ -14,7 +14,7 @@ RFC4422 | |
| <servercmd> | |
| AUTH EXTERNAL | |
| REPLY AUTHENTICATE + | |
| - | REPLY dXNlcg== A002 OK AUTHENTICATE completed |
| + | REPLY %b64[user]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,7 +45,7 @@ IMAP external authentication | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE EXTERNAL | |
| - | dXNlcg== |
| + | %b64[user]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -45,7 +45,7 @@ IMAP external authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| - | A002 AUTHENTICATE EXTERNAL dXNlcg== |
| + | A002 AUTHENTICATE EXTERNAL %b64[user]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -14,7 +14,7 @@ RFC4616 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTHENTICATE + | |
| - | REPLY c2hhcmVkLW1haWxib3gAdXNlcgBzZWNyZXQ= A002 OK AUTHENTICATE completed |
| + | REPLY %b64[shared-mailbox%00user%00secret]b64% A002 OK AUTHENTICATE completed |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -45,7 +45,7 @@ IMAP plain authentication with alternative authorization identity | |
| <protocol crlf="yes"> | |
| A001 CAPABILITY | |
| A002 AUTHENTICATE PLAIN | |
| - | c2hhcmVkLW1haWxib3gAdXNlcgBzZWNyZXQ= |
| + | %b64[shared-mailbox%00user%00secret]b64% |
| A003 SELECT %TESTNUMBER | |
| A004 FETCH 1 BODY[] | |
| A005 LOGOUT | |
| @@ -16,7 +16,7 @@ RFC5034 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTH + | |
| - | REPLY AHVzZXIAc2VjcmV0 +OK Login successful |
| + | REPLY %b64[%00user%00secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -47,7 +47,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -14,9 +14,9 @@ RFC5034 | |
| <reply> | |
| <servercmd> | |
| AUTH LOGIN | |
| - | REPLY AUTH + VXNlcm5hbWU6 |
| - | REPLY dXNlcg== + UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 +OK Login successful |
| + | REPLY AUTH + %b64[Username:]b64% |
| + | REPLY %b64[user]b64% + %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -47,8 +47,8 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH LOGIN | |
| - | dXNlcg== |
| - | c2VjcmV0 |
| + | %b64[user]b64% |
| + | %b64[secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -15,8 +15,8 @@ RFC5034 | |
| <reply> | |
| <servercmd> | |
| AUTH CRAM-MD5 | |
| - | REPLY AUTH + PDE5NzIuOTg3NjU0MzIxQGN1cmw+ |
| - | REPLY dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== +OK Login successful |
| + | REPLY AUTH + %b64[%3c1972.987654321@curl%3e]b64% |
| + | REPLY %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -51,7 +51,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH CRAM-MD5 | |
| - | dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== |
| + | %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -16,7 +16,7 @@ NTLM | |
| <servercmd> | |
| AUTH NTLM | |
| REPLY AUTH + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| REPLY TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= +OK Login successful | |
| </servercmd> | |
| <data crlf="yes"> | |
| @@ -53,7 +53,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u testuser:testpass | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| RETR %TESTNUMBER | |
| QUIT | |
| @@ -15,8 +15,8 @@ RFC5034 | |
| <reply> | |
| <servercmd> | |
| AUTH DIGEST-MD5 | |
| - | REPLY AUTH + cmVhbG09ImN1cmwiLG5vbmNlPSI1MzAwZDE3YTFkNjk1YmQ0MTFlNGNkZjk2Zjk1NDhjMjNjZWQ2MTc1IixhbGdvcml0aG09bWQ1LXNlc3MscW9wPSJhdXRoIg== |
| - | REPLY dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJwb3AvMTI3LjAuMC4xIixyZXNwb25zZT0xODMxNTU0OGM3ZjNhMzdlNzE2ZmE4ZTkwZGZhYjliNixxb3A9YXV0aA== + cnNwYXV0aD1mZWNiMzZiNzA4NmUwYjk1ZDkwNjQ1OWVmYThjYzI5ZQ== |
| + | REPLY AUTH + %b64[realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",algorithm=md5-sess,qop="auth"]b64% |
| + | REPLY %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="pop/127.0.0.1",response=18315548c7f3a37e716fa8e90dfab9b6,qop=auth]b64% + %b64[rspauth=fecb36b7086e0b95d906459efa8cc29e]b64% |
| REPLY +OK Login successful | |
| </servercmd> | |
| <data crlf="yes"> | |
| @@ -57,7 +57,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH DIGEST-MD5 | |
| - | dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJwb3AvMTI3LjAuMC4xIixyZXNwb25zZT0xODMxNTU0OGM3ZjNhMzdlNzE2ZmE4ZTkwZGZhYjliNixxb3A9YXV0aA== |
| + | %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="pop/127.0.0.1",response=18315548c7f3a37e716fa8e90dfab9b6,qop=auth]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| @@ -16,7 +16,7 @@ RFC6749 | |
| <servercmd> | |
| AUTH XOAUTH2 | |
| REPLY AUTH + | |
| - | REPLY dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB +OK Login successful |
| + | REPLY %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -47,7 +47,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user --oauth2-bearer mF_9.B5f-4.1JqM | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH XOAUTH2 | |
| - | dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -46,7 +46,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret --sasl-ir | |
| <verify> | |
| <protocol crlf="yes"> | |
| CAPA | |
| - | AUTH PLAIN AHVzZXIAc2VjcmV0 |
| + | AUTH PLAIN %b64[%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -15,8 +15,8 @@ RFC5034 | |
| <reply> | |
| <servercmd> | |
| AUTH LOGIN | |
| - | REPLY AUTH + UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 +OK Login successful |
| + | REPLY AUTH + %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -46,8 +46,8 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret --sasl-ir | |
| <verify> | |
| <protocol crlf="yes"> | |
| CAPA | |
| - | AUTH LOGIN dXNlcg== |
| - | c2VjcmV0 |
| + | AUTH LOGIN %b64[user]b64% |
| + | %b64[secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -52,7 +52,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u testuser:testpass --sasl-ir | |
| <verify> | |
| <protocol crlf="yes"> | |
| CAPA | |
| - | AUTH NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | AUTH NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| RETR %TESTNUMBER | |
| QUIT | |
| @@ -46,7 +46,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user --oauth2-bearer mF_9.B5f-4.1JqM --s | |
| <verify> | |
| <protocol crlf="yes"> | |
| CAPA | |
| - | AUTH XOAUTH2 dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | AUTH XOAUTH2 %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -16,7 +16,7 @@ RFC5034 | |
| <servercmd> | |
| AUTH NTLM | |
| REPLY AUTH + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + Rubbish |
| REPLY * -ERR AUTH exchange cancelled by client | |
| </servercmd> | |
| </reply> | |
| @@ -50,7 +50,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u testuser:testpass | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| </protocol> | |
| </verify> | |
| @@ -20,7 +20,7 @@ AUTH CRAM-MD5 PLAIN | |
| REPLY "AUTH CRAM-MD5" + Rubbish | |
| REPLY * -ERR AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 +OK Login successful |
| + | REPLY %b64[%00user%00secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -57,7 +57,7 @@ CAPA | |
| AUTH CRAM-MD5 | |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -17,10 +17,10 @@ RFC5034 | |
| <servercmd> | |
| AUTH NTLM PLAIN | |
| REPLY "AUTH NTLM" + | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= + Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% + Rubbish |
| REPLY * -ERR AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 +OK Login successful |
| + | REPLY %b64[%00user%00secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -56,10 +56,10 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -20,7 +20,7 @@ AUTH DIGEST-MD5 PLAIN | |
| REPLY "AUTH DIGEST-MD5" + Rubbish | |
| REPLY * -ERR AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" + | |
| - | REPLY AHVzZXIAc2VjcmV0 +OK Login successful |
| + | REPLY %b64[%00user%00secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -59,7 +59,7 @@ CAPA | |
| AUTH DIGEST-MD5 | |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -16,7 +16,7 @@ RFC5034 | |
| <servercmd> | |
| AUTH EXTERNAL | |
| REPLY AUTH + | |
| - | REPLY dXNlcg== +OK Login successful |
| + | REPLY %b64[user]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -47,7 +47,7 @@ POP3 external authentication | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH EXTERNAL | |
| - | dXNlcg== |
| + | %b64[user]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -46,7 +46,7 @@ POP3 external authentication with initial response | |
| <verify> | |
| <protocol crlf="yes"> | |
| CAPA | |
| - | AUTH EXTERNAL dXNlcg== |
| + | AUTH EXTERNAL %b64[user]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -110,7 +110,7 @@ http://%HOSTIP:%HTTPPORT/%TESTNUMBER -u testuser:testpass --ntlm -L | |
| <protocol crlf="headers"> | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -122,7 +122,7 @@ Accept: */* | |
| GET /you/%TESTNUMBER0010 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -36,7 +36,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH CRAM-MD5 | |
| - | dXNlciA1YzhkYjAzZjA0Y2VjMGY0M2JjYjA2MDAyMzkxNDE5MA== |
| + | %b64[user 5c8db03f04cec0f43bcb060023914190]b64% |
| </protocol> | |
| # CURLE_LOGIN_DENIED | |
| <errorcode> | |
| @@ -16,7 +16,7 @@ RFC5034 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTH + | |
| - | REPLY c2hhcmVkLW1haWxib3gAdXNlcgBzZWNyZXQ= +OK Login successful |
| + | REPLY %b64[shared-mailbox%00user%00secret]b64% +OK Login successful |
| </servercmd> | |
| <data crlf="yes"> | |
| From: me@somewhere | |
| @@ -47,7 +47,7 @@ pop3://%HOSTIP:%POP3PORT/%TESTNUMBER -u user:secret --sasl-authzid shared-mailbo | |
| <protocol crlf="yes"> | |
| CAPA | |
| AUTH PLAIN | |
| - | c2hhcmVkLW1haWxib3gAdXNlcgBzZWNyZXQ= |
| + | %b64[shared-mailbox%00user%00secret]b64% |
| RETR %TESTNUMBER | |
| QUIT | |
| </protocol> | |
| @@ -153,7 +153,7 @@ Accept: */* | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -170,7 +170,7 @@ Accept: */* | |
| GET /you/%TESTNUMBER0010 HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -15,7 +15,7 @@ RFC4954 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTH 334 PLAIN supported | |
| - | REPLY AHVzZXIAc2VjcmV0 235 Authenticated |
| + | REPLY %b64[%00user%00secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -40,7 +40,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -14,8 +14,8 @@ RFC4954 | |
| <servercmd> | |
| AUTH LOGIN | |
| REPLY AUTH 334 VXNlcm5hbWU6 | |
| - | REPLY dXNlcg== 334 UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 235 Authenticated |
| + | REPLY %b64[user]b64% 334 %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -40,8 +40,8 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH LOGIN | |
| - | dXNlcg== |
| - | c2VjcmV0 |
| + | %b64[user]b64% |
| + | %b64[secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -14,8 +14,8 @@ RFC4954 | |
| <reply> | |
| <servercmd> | |
| AUTH CRAM-MD5 | |
| - | REPLY AUTH 334 PDE5NzIuOTg3NjU0MzIxQGN1cmw+ |
| - | REPLY dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== 235 Authenticated |
| + | REPLY AUTH 334 %b64[%3c1972.987654321@curl%3e]b64% |
| + | REPLY %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -44,7 +44,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH CRAM-MD5 | |
| - | dXNlciA3MDMxNzI1NTk5ZmRiYjVkNDEyNjg5YWEzMjNlM2UwYg== |
| + | %b64[user 7031725599fdbb5d412689aa323e3e0b]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -15,7 +15,7 @@ NTLM | |
| <servercmd> | |
| AUTH NTLM | |
| REPLY AUTH 334 NTLM supported | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= 334 TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% 334 TlRMTVNTUAACAAAAAgACADAAAACGggEAc51AYVDgyNcAAAAAAAAAAG4AbgAyAAAAQ0MCAAQAQwBDAAEAEgBFAEwASQBTAEEAQgBFAFQASAAEABgAYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAwAsAGUAbABpAHMAYQBiAGUAdABoAC4AYwBjAC4AaQBjAGUAZABlAHYALgBuAHUAAAAAAA== |
| REPLY TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= 235 Authenticated | |
| </servercmd> | |
| </reply> | |
| @@ -46,7 +46,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| @@ -14,8 +14,8 @@ RFC4954 | |
| <reply> | |
| <servercmd> | |
| AUTH DIGEST-MD5 | |
| - | REPLY AUTH 334 cmVhbG09ImN1cmwiLG5vbmNlPSI1MzAwZDE3YTFkNjk1YmQ0MTFlNGNkZjk2Zjk1NDhjMjNjZWQ2MTc1IixhbGdvcml0aG09bWQ1LXNlc3MscW9wPSJhdXRoIg== |
| - | REPLY dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJzbXRwLzEyNy4wLjAuMSIscmVzcG9uc2U9YTI3YzQzOTVmMzM4Njc0M2JlMTIyMDdiN2QxMTIxYzUscW9wPWF1dGg= 334 cnNwYXV0aD05ZWE4NTljYjlkOTBjMzdjYTMwZDQ5ZDM1Mzc4NjMwYw== |
| + | REPLY AUTH 334 %b64[realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",algorithm=md5-sess,qop="auth"]b64% |
| + | REPLY %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="smtp/127.0.0.1",response=a27c4395f3386743be12207b7d1121c5,qop=auth]b64% 334 %b64[rspauth=9ea859cb9d90c37ca30d49d35378630c]b64% |
| REPLY 235 Authenticated | |
| </servercmd> | |
| </reply> | |
| @@ -50,7 +50,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH DIGEST-MD5 | |
| - | dXNlcm5hbWU9InVzZXIiLHJlYWxtPSJjdXJsIixub25jZT0iNTMwMGQxN2ExZDY5NWJkNDExZTRjZGY5NmY5NTQ4YzIzY2VkNjE3NSIsY25vbmNlPSIzNDMzMzIzMTM1MzMzMjMxMzYzMzMyMzEzNzMzMzIzMSIsbmM9IjAwMDAwMDAxIixkaWdlc3QtdXJpPSJzbXRwLzEyNy4wLjAuMSIscmVzcG9uc2U9YTI3YzQzOTVmMzM4Njc0M2JlMTIyMDdiN2QxMTIxYzUscW9wPWF1dGg= |
| + | %b64[username="user",realm="curl",nonce="5300d17a1d695bd411e4cdf96f9548c23ced6175",cnonce="34333231353332313633323137333231",nc="00000001",digest-uri="smtp/127.0.0.1",response=a27c4395f3386743be12207b7d1121c5,qop=auth]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| @@ -15,7 +15,7 @@ RFC6749 | |
| <servercmd> | |
| AUTH XOAUTH2 | |
| REPLY AUTH 334 XOAUTH2 supported | |
| - | REPLY dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB 235 Authenticated |
| + | REPLY %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -40,7 +40,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH XOAUTH2 | |
| - | dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -99,7 +99,7 @@ Accept: */* | |
| GET /%TESTNUMBER HTTP/1.1 | |
| Host: %HOSTIP:%HTTPPORT | |
| - | Authorization: NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | Authorization: NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| User-Agent: curl/%VERSION | |
| Accept: */* | |
| @@ -39,7 +39,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <verify> | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| - | AUTH PLAIN AHVzZXIAc2VjcmV0 |
| + | AUTH PLAIN %b64[%00user%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -14,8 +14,8 @@ RFC4954 | |
| <reply> | |
| <servercmd> | |
| AUTH LOGIN | |
| - | REPLY AUTH 334 UGFzc3dvcmQ6 |
| - | REPLY c2VjcmV0 235 Authenticated |
| + | REPLY AUTH 334 %b64[Password:]b64% |
| + | REPLY %b64[secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -39,8 +39,8 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <verify> | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| - | AUTH LOGIN dXNlcg== |
| - | c2VjcmV0 |
| + | AUTH LOGIN %b64[user]b64% |
| + | %b64[secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -45,7 +45,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <verify> | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| - | AUTH NTLM TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | AUTH NTLM %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAABwAAAACAAIAHAAAAALAAsAeAAAAAAAAAAAAAAAhoIBAFpkQwKRCZFMhjj0tw47wEjKHRHlvzfxQamFcheMuv8v+xeqphEO5V41xRd7R9deOXRlc3R1c2VyV09SS1NUQVRJT04= | |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| @@ -39,7 +39,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <verify> | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| - | AUTH XOAUTH2 dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | AUTH XOAUTH2 %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -15,7 +15,7 @@ RFC4954 | |
| <servercmd> | |
| AUTH NTLM | |
| REPLY AUTH 334 NTLM supported | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= 334 Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% 334 Rubbish |
| REPLY * 501 AUTH exchange cancelled by client | |
| </servercmd> | |
| </reply> | |
| @@ -49,7 +49,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| </protocol> | |
| </verify> | |
| @@ -19,7 +19,7 @@ AUTH CRAM-MD5 PLAIN | |
| REPLY "AUTH CRAM-MD5" 334 Rubbish | |
| REPLY * 501 AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" 334 PLAIN supported | |
| - | REPLY AHVzZXIAc2VjcmV0 235 Authenticated |
| + | REPLY %b64[%00user%00secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -50,7 +50,7 @@ EHLO %TESTNUMBER | |
| AUTH CRAM-MD5 | |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -16,10 +16,10 @@ RFC4954 | |
| <servercmd> | |
| AUTH NTLM PLAIN | |
| REPLY "AUTH NTLM" 334 NTLM supported | |
| - | REPLY TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= 334 Rubbish |
| + | REPLY %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% 334 Rubbish |
| REPLY * 501 AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" 334 PLAIN supported | |
| - | REPLY AHVzZXIAc2VjcmV0 235 Authenticated |
| + | REPLY %b64[%00user%00secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -49,10 +49,10 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH NTLM | |
| - | TlRMTVNTUAABAAAABoIIAAAAAAAAAAAAAAAAAAAAAAA= |
| + | %b64[NTLMSSP%00%01%00%00%00%06%82%08%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00]b64% |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -19,7 +19,7 @@ AUTH DIGEST-MD5 PLAIN | |
| REPLY "AUTH DIGEST-MD5" 334 Rubbish | |
| REPLY * 501 AUTH exchange cancelled by client | |
| REPLY "AUTH PLAIN" 334 PLAIN supported | |
| - | REPLY AHVzZXIAc2VjcmV0 235 Authenticated |
| + | REPLY %b64[%00user%00secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -52,7 +52,7 @@ EHLO %TESTNUMBER | |
| AUTH DIGEST-MD5 | |
| * | |
| AUTH PLAIN | |
| - | AHVzZXIAc2VjcmV0 |
| + | %b64[%00user%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -16,8 +16,8 @@ RFC4954 | |
| <servercmd> | |
| AUTH PLAIN | |
| REPLY AUTH 334 PLAIN supported | |
| - | REPLY dXNlci5vbmUAdXNlci5vbmUAc2VjcmV0 235 Authenticated |
| - | REPLY dXNlci50d28AdXNlci50d28Ac2VjcmV0 235 Authenticated |
| + | REPLY %b64[user.one%00user.one%00secret]b64% 235 Authenticated |
| + | REPLY %b64[user.two%00user.two%00secret]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -43,14 +43,14 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER002 --mail-rcpt [email protected] --mail | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER001 | |
| AUTH PLAIN | |
| - | dXNlci5vbmUAdXNlci5vbmUAc2VjcmV0 |
| + | %b64[user.one%00user.one%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| QUIT | |
| EHLO %TESTNUMBER002 | |
| AUTH PLAIN | |
| - | dXNlci50d28AdXNlci50d28Ac2VjcmV0 |
| + | %b64[user.two%00user.two%00secret]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -15,7 +15,7 @@ RFC4954 | |
| <servercmd> | |
| AUTH EXTERNAL | |
| REPLY AUTH 334 EXTERNAL supported | |
| - | REPLY dXNlcg== 235 Authenticated |
| + | REPLY %b64[user]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -40,7 +40,7 @@ mail body | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH EXTERNAL | |
| - | dXNlcg== |
| + | %b64[user]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -39,7 +39,7 @@ mail body | |
| <verify> | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| - | AUTH EXTERNAL dXNlcg== |
| + | AUTH EXTERNAL %b64[user]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |
| @@ -13,7 +13,7 @@ UPLOAD | |
| <servercmd> | |
| AUTH OAUTHBEARER XOAUTH2 | |
| REPLY AUTH 334 XOAUTH2 supported | |
| - | REPLY dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB 235 Authenticated |
| + | REPLY %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% 235 Authenticated |
| </servercmd> | |
| </reply> | |
| @@ -38,7 +38,7 @@ smtp://%HOSTIP:%SMTPPORT/%TESTNUMBER --mail-rcpt [email protected] --mail-fr | |
| <protocol crlf="yes"> | |
| EHLO %TESTNUMBER | |
| AUTH XOAUTH2 | |
| - | dXNlcj11c2VyAWF1dGg9QmVhcmVyIG1GXzkuQjVmLTQuMUpxTQEB |
| + | %b64[user=user%01auth=Bearer mF_9.B5f-4.1JqM%01%01]b64% |
| MAIL FROM:%[email protected]%GT | |
| RCPT TO:%[email protected]%GT | |
| DATA | |